Search results

System Requirements for Vue UI Components

25 Jan 2023 / 1 minute to read

This section explains the basic system requirements to work with Syncfusion Vue UI components.

  • Vue supported version >= 2.6+.
  • Required vue-class-component package.
  • Vue 2.6 - Use the 7.2.6 version.
  • Vue 2.7 - This package is not needed.
  • Vue 3+ - Use ^8.0.0-rc.1 version.
  • Required node version >= 16+, and the supported npm version will be installed along with the node version. Use the following command to check the node’s version.
Copied to clipboard
node --version

Browser support

The Syncfusion Vue UI components are supported only in modern browsers. For more information, refer to the browser compatibility section.

Vue supported versions

The following table represents the supported Vue versions by different Syncfusion Vue UI components releases.

Version Syncfusion Vue components version
Vue v2.7 20.3.47 and above
Vue v3.0 19.2.44 and above