System Requirements for React Components

17 Feb 20231 minute to read

This section explains the basic system requirements to work with Syncfusion React UI components.

  • React supported version >= 15.5.4+.

  • Required node version >= 14.0.0+, and the supported npm version will be installed along with the node version. Use the below command to check the node version.

node --version
  • For Yarn package manager, the Yarn version >= 0.25+ is required.

Browser support

The Syncfusion React UI components are supported only in modern browsers. Refer to the browser compatibility section for more information.

React supported versions

The following table represents the supported React versions by different Syncfusion React UI components releases.

Version Syncfusion React components version
React v18.0 20.2.36 and above
React v17.0 18.3.50 and above
React v16.0 16.2.45 and above

See also