System Requirements for ASP .NET Core EJ2 Components

1 Aug 20221 minute to read

To get started with ASP.NET Core application, ensure the following software to be installed in the machine.

Integrated Development Environment

ASP.NET Core Applications can be developed using one of the following IDEs. You can also develop using .NET CLI without below IDEs.

Framework & SDK

One of the the following .NET SDK is required to develop and run the Syncfusion UI controls for ASP.NET Core application.

If you are planning to use Visual Studio to develop ASP.NET Core Applications.

  • .NET 6.0 requires Visual Studio 2022 17.0 or later.
  • .NET 5.0 requires Visual Studio 2019 16.8 or later.
  • .NET Core SDK 3.1 requires Visual Studio 2019 16.4 or later.
  • .NET Core SDK 2.0 requires Visual Studio 2017 15.7 or later.
  • .NET 4.5 Framework requires Visual Studio 2015 20.1 or later